Recent Posts

Pages: [1] 2 3 ... 10
1
General Discussion / "Dead Easy" pump, fittings thread
« Last post by Des28Qau on Today at 04:35:08 AM »
Hi Guys,
Has anyone reconditioned or have, a dead easy air pump ? and the ability to identify the thread used for the air fittings ? And is the top fittings thread the same as the link pipe/tube thread?
I have just cleaned up an shabby looking pump , greased up the leathers and joints, cleaned up and painted the castings , polished the cylinders and cleaned up the check-valves & bolts, then rebuilt. On testing I find the balance pipe/tube cracked was (not desturbed) and is leaking .
I have taken the top castings to a local pipe hose & fitting (mostly hydraulics) shop, but they could not match.
If I can match (prefered) the thread great or I will just have to tap the castings M6 or 1/8npt or what ever can work for me.
Thanks in anticipation .
Regards Des.


2
General Discussion / Re: Need Some Help
« Last post by Crazydave on Today at 03:59:19 AM »
Have been short on time this week, if you need any details let me know. The white wire with the speedo cable was (is) my temporary fuel pump power. Ignore. Followed YNZ's setup for the most part. They have power for the clum fed from the horn, that is why there are 2 green wires. (I know its the wrong horn) If anyone has an extra right one they want to part with let me know.






3
General Discussion / Re: Exhaust system question
« Last post by Articifer Tom on Today at 03:44:53 AM »
That is probably  why the first clamp is way back at muffler gives motor , little flex that they seem to have , time to work . I am going to see about getting a few measurements from .
4
General Discussion / Re: Exhaust system question
« Last post by frankp on Today at 01:55:24 AM »
As I recall, all of my hangers are tight with no play.
5
General Discussion / Re: Exhaust system question
« Last post by chetbrz on February 23, 2018, 10:57:24 PM »

Nice Picture, It explains a lot.

The entire exhaust system of the 29 Sedan seems to be a hard ridged mount.  Most exhaust systems float and allow for some play and engine to frame movement.  The 29 engine is virtually hard mounted even with the rubber motor mounts, so I guess it doesn't matter very much.  Anyone have any thoughts on the matter.  Maybe the mounts should not be tightened around the pipe to allow for some minor movement even frame flex ?

Thanks Tom.
6
General Discussion / Re: Exhaust system question
« Last post by Articifer Tom on February 23, 2018, 09:00:01 PM »
Here is rear bracket pic . Looks to be two piece as in lube charts . Guess I'll make up one for my truck .
7
General Discussion / Re: Exhaust system question
« Last post by racertb on February 22, 2018, 06:50:14 PM »
My exhaust set up looks a lot like Frank's...the hangar looks the same/similar to John's photo.
8
General Discussion / Re: Exhaust system question
« Last post by frankp on February 22, 2018, 06:27:29 AM »
John, it could be.  The 2 holes reminds me of the front bracket for the exhaust pipe on the bell housing.   frank
9
General Discussion / Re: Exhaust system question
« Last post by 29UJohn on February 22, 2018, 05:11:31 AM »
Is this the bracket?  It was in my box of left over parts from when I purchased the car in 1973.  (It may have been modified at some point with extra holes before I bought the car.)
10
General Discussion / Re: Need Some Help
« Last post by chetbrz on February 22, 2018, 01:22:39 AM »

Thanks Dave
Pages: [1] 2 3 ... 10